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CHAPTER

ONE

WHAT IS QGREENLAND?

QGreenland is a free and open-source Greenland-focused GIS environment for data analysis and viewing, powered by
QGIS1. QGreenland is delivered as a Zip package containing a core set of data curated to serve a broad user base. This
package is referred to as QGreenland Core.

See our tutorial on how to get started with QGreenland Core here (page 12)!

Attention: The QGIS Plugin QGreenland Custom2 (beta) is no longer supported. This was an experiment, and
we decided to go in a different direction. It should not be expected to work.

Visit the QGreenland website3

1 https://qgis.org
2 https://plugins.qgis.org/plugins/qgreenland/
3 https://qgreenland.org
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CHAPTER

TWO

WHAT QGREENLAND IS NOT

• The QGreenland project is not a data-production project. While we do process existing data, it is only to enable
efficient and effective viewing in the QGreenland QGIS environment.

• QGreenland is not a navigational aid. Please see our Disclaimer (page 10).
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CHAPTER

THREE

ABOUT QGIS

QGIS is a free and open source Geographic Information System (GIS) licensed under the GNU General Public License.
QGreenland is designed to be used by a diverse user group, from scientists to planners and policymakers to educators,
and more. QGreenland users are able to produce high-quality mapping products to meet their unique needs. And
because the QGreenland data package is downloaded right onto the user’s computer, QGreenland can be used in the
field and in remote places without Internet access. Some additional larger datasets (e.g., satellite imagery) not included
with the main QGreenland download package are available through online access when connected. QGreenland was
inspired by the free and open source Quantarctica4 GIS data package for Antarctica.

4 https://www.npolar.no/en/quantarctica/
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CHAPTER

FOUR

QGREENLAND CORE DOWNLOAD PACKAGE

You will find the following files in the QGreenland Core data package:

• Folders containing data layers organized by topic. Each data layer is represented as a GeoTIFF or GeoPackage.

• qgreenland.qgz - The main QGreenland project file for QGIS

• qgreenland.png - The official QGreenland logo

• layer_list.csv - A complete list of all the data layers in the QGreenland Core download package, including infor-
mation about each (data source, file size, etc.). This file can be opened with Microsoft Excel, LibreOffice Calc,
a text editor, or a similar program.

• UserGuide.pdf - The full QGreenland Core User Guide

• QuickStartGuide.pdf - A one-page overview guide for experienced QGIS users on how to download the
QGreenland Core data package and other information

• STYLE.txt - Guidelines and standards for QGreenland data layer styling

• README.txt - Brief description of the QGreenland data package

• CHANGELOG.txt - A log of changes made to the QGreenland data package

Please note that QGreenland Core v1.0.0 is the first stable public release version from this project. The QGreenland
Core v2.0.0 download package was released in March 2022. The QGreenland Core v3.0.0 download package was
released in August 2023. Development versions along the way will continue to be available via the website5, with code
fully documented on GitHub6.

Although the v3.0.0 download package contains a full User Guide, updates and additions are constantly being made
to our documentation as we continue to develop QGreenland. The most recent version of QGreenland documentation
will always be available here on Read the Docs.

5 http://qgreenland.org
6 https://github.com/nsidc/qgreenland
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CITING QGREENLAND CORE AND CUSTOM

We request that the QGreenland project be cited or acknowledged when publishing a QGreenland-made image or map.

QGreenland development is open source and available on GitHub7. This means that users are free to create their own
customized QGreenland package with different and new styles, layers, and data. Users who wish to contribute to the
QGreenland project will find instructions on how to do this in the Contributor How-to section on Readthedocs.

QGreenland is licensed under an MIT license: Permission is hereby granted, free of charge, to any person obtaining a
copy of this software and associated documentation files (the “Software”), to deal in the Software without restriction,
including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies
of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:
The above copyright notice and this permission notice shall be included in all copies or substantial portions of the
Software.

Users should note that published works produced using QGreenland are required to cite each dataset used in the work.
QGreenland provides all dataset citation information in each layer’s metadata in QGIS (see the Layer Properties section
in the Interacting with Geospatial Data tutorial (page 21) for instructions on how to access a layer’s metadata) and in the
layer catalog provided with the QGreenland download package, layer_list.csv. You are also required to acknowledge
or cite QGreenland and the National Snow and Ice Data Center in your work.

5.1 Citation

Please note that QGreenland currently has two citable components:

• The QGreenland QGIS data package is cited as [dataset] and used by researchers and educators.

• The software used to generate the QGIS data package from source data is cited as [software] and used by
software developers.

Please choose the appropriate citation depending on which you use.

An asterisk (*) indicates co-equal lead authorship (listed alphabetically).
7 https://github.com/nsidc/qgreenland
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5.1.1 Latest version: v3.0.0

Moon, T. A., M. Fisher, T. Stafford, and A. Thurber (2023). QGreenland (v3.0.0) [dataset], National Snow
and Ice Data Center8.

*Fisher, M., *Stafford, T., T. Moon, and A. Thurber (2023). QGreenland (v3.0.0) [software], National
Snow and Ice Data Center9

5.1.2 Version 3

Moon, T. A., M. Fisher, T. Stafford, and A. Thurber (2023). QGreenland (v3) [dataset], National Snow
and Ice Data Center10.

*Fisher, M., *Stafford, T., T. Moon, and A. Thurber (2023). QGreenland (v3) [software], National Snow
and Ice Data Center11

5.1.3 Version 2

Moon, T., Fisher, M., Harden, L., Simonoko, H., and T. Stafford (2022). QGreenland (v2) [dataset],
National Snow and Ice Data Center12.

*Fisher, M., *Stafford, T., Moon, T., Harden, L., and H. Simonoko (2022). QGreenland (v2) [software],
National Snow and Ice Data Center13

5.1.4 Version 1

Moon, T., Fisher, M., Harden, L., and T. Stafford (2021). QGreenland (v1) [dataset], National Snow and
Ice Data Center14.

*Fisher, M., *Stafford, T., Moon, T., and L. Harden (2021). QGreenland (v1) [software], National Snow
and Ice Data Center15

5.2 Acknowledgement

We acknowledge the National Snow and Ice Data Center QGreenland package.

8 https://qgreenland.org/
9 https://github.com/nsidc/qgreenland

10 https://qgreenland.org/
11 https://github.com/nsidc/qgreenland
12 https://qgreenland.org/
13 https://github.com/nsidc/qgreenland
14 https://qgreenland.org/
15 https://github.com/nsidc/qgreenland
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6.1 Prior art

The Quantarctica16 project inspired QGreenland. Our innovation on this prior work is open-source and reproducible
package creation. Thank you!

6.2 Funding

The U.S. National Science Foundation grant #192839317 funded the development of QGreenland versions 1.x, 2.x,
and 3.x. Thank you!

6.3 Editorial board

The QGreenland Editorial Board18 made it possible for QGreenland to cover a wide variety of scientific disciplines at
high quality. Thank you!

6.4 Open-source software

QGreenland would not have been possible without the following open-source projects. This is not an exhaustive list –
if your project is listed in our environment-lock.yml file, thank you!

• QGIS19

• cmocean20

• Python21

• Luigi22

16 https://www.npolar.no/en/quantarctica/
17 https://nsf.gov/awardsearch/showAward?AWD_ID=1928393
18 https://qgreenland.org/our-team
19 https://www.qgis.org/
20 https://github.com/matplotlib/cmocean
21 https://www.python.org
22 https://github.com/spotify/luigi
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• GDAL23

• Docker24

6.5 Project Collaborators

QGreenland is developed by researchers, software developers, and education specialists at the National Snow and Ice
Data Center and Cooperative Institute for Research in Environmental Sciences at the University of Colorado Boul-
der. The QGreenland project is funded by the U.S. National Science Foundation EarthCube program under grant
#1928393. The QGreenland project is advised by an Editorial Board consisting of international content experts in
remote sensing and GIS, cryospheric and geologic sciences, ecology, climate modeling, and more. Other project col-
laborators include: The Geological Survey of Denmark and Greenland (De Nationale Geologiske Undersøgelser for
Danmark og Grønland), Technical University of Denmark (Dansmarks Tekniske Universitet), Danish Meteorological
Institute (Dansmarks Meteorologiske Institut), Asiaq - Greenland Survey, Norwegian Polar Institute (Norsk Polarinsti-
tutt), Arctic Data Committee, International Arctic Science Committee, WWF-Danmark, U.S. Polar Geospatial Center,
Greenland Ice Sheet Ocean Science Network, N.S.F. Polar Computing RCN, and Isaafik. More information about the
QGreenland team and collaborators is available at the website http://qgreenland.org.

23 https://gdal.org
24 https://www.docker.com/
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DISCLAIMER

QGreenland should not be used as a sole navigational aid while performing remote research activities in Greenland or
elsewhere. Always bring appropriate safety and navigational aids (including hard-copies of topographic maps) when
visiting the field.

QGreenland is a data-viewing and analysis platform, and the QGreenland Team does not create new data. QGreenland’s
layers may contain errors from the original data providers. QGreenland makes no guarantees about the accuracy and
validity of data contained in QGreenland. Limited notes on known data issues have been added to the ‘Populated
places’ layer metadata. Also, some layers may not perfectly align with each other due to unidentified georeferencing
issues with the original data. We recommend using the ‘Greenland coastlines 2017’ layer as the best approximation
reference layer for geolocating Greenland’s coastline.

Note that some data were transformed from their native data formats, projections, and resolutions for inclusion within
QGreenland. The included metadata (Layer Properties -> Metadata -> History) contains provenance information on
any transformations. All QGreenland GeoPackages and GeoTIFFs are projected in EPSG:3413.

10
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TUTORIALS

8.1 Get started with QGreenland Core

By completing this tutorial, the user will install QGIS, download and open the QGreenland Core data package, become
familiar with the QGIS interface, and browse some data included in QGreenland.

8.1.1 System Requirements

Before downloading the QGreenland Core data package, be sure that QGIS is installed on your computer: https://www.
qgis.org/en/site/forusers/download.html. QGIS is available on Windows, macOS, Linux and Android.

As of this writing, the oldest version of QGIS we support for the QGreenland release series are:

• QGreenland 1.x: QGIS 3.16.x LTR

• QGreenland 2.x: QGIS 3.16.x LTR

• QGreenland 3.x: QGIS 3.28.x LTR

8.1.2 1) Download and Install QGIS

Go to qgis.org25 and download the free QGIS software, available on Windows, macOS, Linux and Android. It is
recommended to download the long term release (3.16 or later) version.

8.1.3 2) Download and open the QGreenland Core package

Download the QGreenland Core data package (v3.0.0) at https://qgreenland.org/download.

Save the zip package to a location of your choice and unzip it.

Warning: Ensure QGreenland is actually unzipped; some operating systems will only “explore” a zip file when
you double-click it without actually extracting it to disk. In Windows, please right-click and select Extract all.
...

Open the qgreenland.qgz file in the data package folder by double-clicking it. QGIS will open automatically and
display the QGreenland Core data environment.

25 https://qgis.org
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Note: Depending on your version of QGreenland Core, the package may be a .qgs or a .qgz file. They should
function the same as long as you have a compatible version of QGIS.

Note: If QGIS is already open, one can open the qgreenland.qgz project file within QGIS by navigating to the
Project -> Open. . . option in the menu bar and selecting the qgreenland.qgz file from its saved location.

8.1.4 3) Get to know the QGIS Interface

In this user guide you will see various screenshots of the QGreenland Core and QGIS interface. The screenshots in this
guide were generated from QGIS version 3.16 running on a macOS Catalina operating system; thus, depending on the
operating system and QGIS version you are using, your QGIS interface may look slightly different.

The main components of the QGIS interface are the Map view, Status bar, Layers panel, Toolbars, and the Menu
bar.

Fig. 8.1: Main components of the QGIS/QGreenland interface.

The Map View is the main part of the QGIS/QGreenland Core interface where the data layers are displayed. A GIS
‘layer’ refers to a geospatial dataset along with the symbols and labels used to portray it in a GIS environment.

The Status bar is the bar at the bottom of the QGIS window that shows the current coordinate reference system of the
Map View, any available plugin updates, and the Map view scale. Also included in the Status bar is a quick search
bar and a button to open a Log Messages window to view log messages.

The Layers Panel is where all data layers in the current project are listed. Layers can be toggled on or off, which will
control whether or not they show up in the Map View. Layers are listed in the order in which they show up in the Map
View - layers at the top of the list show up on top in the Map View, and vice versa. Layers can be manually moved
around in the Layers Panel to change the order in which they show up. Panels and Toolbars can also be manually
moved around the QGIS interface to fit the user’s preferences.
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When you first open the QGreenland Core data package, two reference layers will be automatically toggled on: Green-
land coastlines 2017 and the QGreenland Basemap. Layers can be rearranged by clicking and dragging up or down.
Layer groups can be expanded or collapsed by clicking on the arrow to the left of the checkbox. To expand or collapse
all layers at once, click on the respective buttons (Fig. 8.2 (a)) right above the layers list in the Layers Panel. In addition
to the Layers Panel, there are a variety of other panels that can be displayed on the QGIS interface. For example, the
Browser Panel provides a shortcut for accessing other data layers or project files on your computer or another location.
Panels can be moved around the interface by clicking and dragging, and can be removed by clicking on the ‘X’ box in
the upper righthand corner.

Fig. 8.2: (a) Expand All and Collapse All buttons at the top of the Layers Panel to expand or collapse layers; (b) Pan
Map button in the Map Navigation Toolbar to grab and drag the map view; (c) Zoom In and Zoom Out buttons in
the Map Navigation Toolbar to zoom in or out in map view; (d) Zoom Full button in the Map Navigation Toolbar
to bring all visible layers into the Map View; (d) Zoom to Layer button in the Map Navigation Toolbar to bring a
desired layer into view.

The Toolbars contain buttons that allow the user to interact with the Map View. For example, the Pan Map button
(Fig. 8.2 (b)) in the Map Navigation Toolbar lets the user grab and drag the map view around. The magnifying glass
buttons (Fig. 8.2 (c)) allow the user to zoom in and out or to a particular feature or selection in the map view. More
information about a toolbar button’s function can be obtained by hovering one’s mouse over the button. Toolbars can
be moved around the QGIS workspace by clicking and dragging. To toggle a toolbar on or off, simple right click on a
toolbar and check or uncheck the desired boxes (Fig. 8.3).

If data layers are toggled on but not visible in the map view, the magnifying glass with three arrows (Zoom Full) button
(Fig. 8.2 (d)) will bring all visible layers back into the map view. Right clicking on a layer in the Layers Panel and
selecting Zoom to Layer or clicking on the magnifying glass over a square button (Fig. 8.2 (e)) in the Map Navigation
Toolbar will also bring a desired layer into view in the Map View.

Lastly, the Menu bar and Toolbars are different ways to access most QGIS functions, such as opening or saving a
project or analyzing the data using geoprocessing tools. Panels are another way for users to interact with data layers
and functions in QGIS. You can fully customize the look and layout of your QGIS interface by going to ‘View’ in the
menu bar and selecting the Panels, Toolbars, etc. that you would like visible.

Note: The QGIS User Manual26 provides a detailed and comprehensive overview of QGIS’ core features. Users who
are new to Geographic Information Systems may also benefit from reviewing QGIS’s Gentle Introduction to GIS27

26 https://docs.qgis.org/3.28/en/docs/user_manual/index.html
27 https://docs.qgis.org/3.28/en/docs/gentle_gis_introduction/index.html
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Fig. 8.3: Toolbars can be added or removed by right clicking on the toolbar area and checking/unchecking boxes.
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8.1.5 4) Browse data in the QGreenland project

Layers in QGreenland Core are organized into groups by category. For example, the “Background boundary” layer
is “QGreenland boundaries” group, which is itself inside of the “Reference” group (“Reference/QGreenland bound-
aries/Background boundary”).

Toggle layer visibility

Some layers are turned on by default when opening the QGreenland Core project. In order to visualize another data
layer (or remove an existing one), toggle the checkbox next to the layer in the Layers panel.

Toggle on the “Ice thickness (150m)” layer, which is in the “Terrain models/Bedmachine v5” group. The Map view
should now include a visualization of Ice thickness at a 150m spatial resolution.

Note: The search bar, located in the Status bar, can also be used to find layers in the Layers panel.

8.1. Get started with QGreenland Core 16
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Navigate the Map View

The Map view can be interacted with using a combination of the mouse and the Map Navigation Toolbar

By default, the Pan Map tool is selected . This tool allows the user to click and drag on the map view to change
the extent. Try using this tool to pan around the map and explore the geography surrounding Greenland.

The zoom tools can be used to zoom in and out of the map view. Select the Zoom In tool and use it to
draw a box around southern Greenland to get a better look at the “Ice thickness (150m)” layer in that part of Greenland.
Now select the Pan Map tool again and explore the layer in detail.

Note: The scroll wheel on your mouse or track pad can also be used to zoom in and out in the Map view

Hovering over the other map navigation tool icons will provide a tool tip indicating what the tool is used for. Try
hovering over some of the other icons in the Map Navigation Toolbar to read their tooltips. Try out some of these
other tools to explore the map and QGreenland’s various data layers. See the QGIS documentation on zooming and
panning28 for more detailed information on how to effectively navigate the Map View.

28 https://docs.qgis.org/3.28/en/docs/user_manual/introduction/general_tools.html#zooming-and-panning
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8.1.6 5) Summary

In completing this tutorial, the user has installed QGIS, downloaded and opened the QGreenland Core data package, and
learned about the fundamentals of using QGIS to explore QGreenland. Having accomplished this, the user is prepared
to explore the many data layers included with QGreenland Core. The user is now ready to approach more advanced
topics such as performing geospatial analyses and preparing publication-quality maps with the data in QGreenland
Core.

8.2 Beginner Video Series

8.2.1 Overview

In this video series, you will become familiar with QGIS, learn how to download and browse the QGreenland Core
data package, and explore the basic geospatial data anlysis tools that make QGreenland a powerful tool for research,
education, and local decision making. The video tutorial series contains 7 short video sessions.

Goals

• Learn what data is included in the QGreenland Core Package

• Analyze Greenland data using geoprocessing tools

• Find analysis tools and data relevant to you or your classes

Total Time: 1 hour

In order to get the most out of this series, we recommend the following:

• Install QGIS on your computer. Go to qgis.org29 and download the free QGIS software. QGIS version 3.16 is
the oldest version supported by QGreenland

• Download the QGreenland Core data package at https://qgreenland.org/download

• When watching the videos, click on the settings icon to adjust the subtitles (in English or other languages) and
adjust the playback speed

• Take time to engage in the practice tasks and take notes

Session 1: Introduction to QGreenland30

• This video will introduce you to geographic information systems (GIS) and what it can be used for.
29 https://www.qgis.org/
30 https://www.youtube.com/watch?v=gD0vkP5JUmA&amp;list=PLSRiyMridUCwyu-vqpAFtm8bVERgTvs7q&amp;index=1
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Session 2: Introduction to QGIS and QGreenland Core PackagePage 19, 31

• How to download QGIS and QGreenland Core package

• Obtain a general understanding of what GIS and QGreenland are

• Explore the QGreenland Core package folders

Session 3: Navigating the Core package32

• Navigate the QGIS interface

• Toggle panels on and off

• Turn toolbars on and off

Session 4: Layers and Properties33

• Access properties, attributes, and metadata of layers

• Know the difference between vector and raster layers

• Identify different layer types in Layers Panel

• Change display or symbology of layers

Session 5: Processing Toolbox and Data Analysis34

• Locate and open the processing toolbox

• Select by attribute in a vector layer

• Run basic statistics on a vector attribute field including sum, mean, and range

• Calculate the surface volume area of a raster layer

Note: The “Populated places” layer referred to in this video has been updated and moved from “Places/Community
map (crowd-sourced)” to the root of the “Places/” layer group in QGreenland v3.

This updated “Populated places” layer has a “Population 2016” attribute that should be used instead of the “population”
attribute indicated in the video.

31 https://www.youtube.com/watch?v=u8exrxhwme4&amp;list=PLSRiyMridUCwyu-vqpAFtm8bVERgTvs7q&amp;index=2
32 https://www.youtube.com/watch?v=WhboP5u5HqE&amp;list=PLSRiyMridUCwyu-vqpAFtm8bVERgTvs7q&amp;index=3
33 https://www.youtube.com/watch?v=hAMw-_dFWng&amp;list=PLSRiyMridUCwyu-vqpAFtm8bVERgTvs7q&amp;index=4
34 https://www.youtube.com/watch?v=znKeiV3-Amo&amp;list=PLSRiyMridUCwyu-vqpAFtm8bVERgTvs7q&amp;index=5
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Session 6: Editing Existing and New LayersPage 20, 35

• Edit existing layers in the QGreenland Core Package

• Create a new Vector layer

• Manage layer locations and removal of layers

Session 7: Preparing Map for Export and Publication36

• Export a QGreenland Map for publication

8.3 Interacting with Geospatial Data in QGreenland Core

Note: QGreenland users will learn through experience that there is very often more than one way to complete a desired
task in the QGIS platform

8.3.1 Spatial Data Overview

There are two main basic kinds of GIS data layers: vector and raster.

Vector Data

Vector data are composed of points, lines, and polygons and represent discrete features. Examples of vector data are
cities (points), roads and highways (lines), and geographic boundaries like country borders (polygons) (Fig. 8.4). All
of the vector layers in QGreenland are GeoPackage (.gpkg) files. A GeoPackage is just a platform-independent file type
for storing geospatial data.

Vector Data Attributes

All QGIS vector data layers have associated attributes, or characteristics of the discrete features. Attributes can be
almost anything: city name, road type (highway, paved, unpaved, etc.), land elevation value, population density, date,
etc. The attributes of a data layer can be viewed in tabular form by right clicking on the layer in the Layers Panel
and selecting Open Attribute Table from the menu options, or by clicking on the layer in the Layers Panel and then
clicking on the Open Attribute Table button in the Attributes Toolbar. This opens up an Attribute Table, where the
columns are the various fields, or attributes, and the rows are individual features. Clicking on and highlighting records
in the Attribute Table will also highlight those specific points, lines, or polygons in the Map View. Right-click any
cell to Zoom to feature, Pan to feature, or Flash feature.

35 https://www.youtube.com/watch?v=98nF6YJAnns&amp;list=PLSRiyMridUCwyu-vqpAFtm8bVERgTvs7q&amp;index=6
36 https://www.youtube.com/watch?v=6YG_Jc7HcOo&amp;list=PLSRiyMridUCwyu-vqpAFtm8bVERgTvs7q&amp;index=7
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Fig. 8.4: Examples of vector data layers in QGreenland Core: points (towns and settlements), lines (median January
sea ice extent), and polygons (country boundaries).

Raster Data

Raster data are composed of grid cells or pixels, where each grid cell has its own value. Rasters represent continuous
data, such as land elevation, surface temperature, land cover, etc. (Fig. 8.5). The resolution, which is the length of the
grid cell sides of each raster dataset in QGreenland, is indicated in the name of the dataset, e.g.: “Ice Sheet Velocity (500
m)”. Raster layers in QGreenland are all GeoTIFF files, which are images with geographic features, such as geospatial
metadata and overviews/tile pyramids.

8.3.2 Layer Properties

Right clicking on a data layer in the Layers Panel and selecting Properties, or simply double clicking on a layer in
the Layers panel will bring up the Layer Properties dialog window, which contains a variety of information about a
layer (Fig. 8.6). The information is organized into sections (or tabs) that can be accessed by clicking on an individual
tab (e.g., Symbology) in the left sidebar of the window. The tabs listed in a vector Layer Properties dialog window
differ slightly from those listed for a raster layer. The tabs most relevant to a novice QGIS user and that exist for both
vector and raster layers are:

• Information: This section summarizes information about a layer, including its name, coordinate reference sys-
tem, spatial extent (geographic boundaries), description (abstract), and more.

• Symbology: Every QGreenland data layer has a predefined symbology, or visual representation in the map view.
See section 5.4: Editing Layer Symbology for instructions on how to modify or customize a layer’s symbology.

• Metadata: Metadata is essentially “data about data”. In QGIS, layer metadata is information about the data in
the layer, including its name, description, citation, and link to the source that the data was retrieved from. As
outlined in Licensing, Citing, and Contributing, published works produced using QGreenland are required to
cite each dataset used in the work. Users can thus simply copy a layer’s citation directly from its metadata. An
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Fig. 8.5: Example of a Raster data layer in QGreenland, ice sheet velocity, where each grid cell in the raster is 500 m
x 500 m and is color-coded by a velocity

abbreviated version of a layer’s metadata can also be viewed by selecting a layer in the Layers panel and hovering
your mouse over the layer name.

Note: The QGreenland team has in a few instances included comments on ‘Noted Data Issues’. Read about ‘Noted
Data Issues’ in the layer metadata. These are currently noted for the ‘Populated places’ layer. Regardless, QGreenland
makes no guarantees about the accuracy and validity of data contained in QGreenland. See our Disclaimer (page 10)
for more information.

8.3.3 Coordinate Reference System (CRS)

Coordinate Reference Systems (CRS), define the coordinate system for a QGIS project and data layers. The CRS for
the current Map View is indicated on the right side of the QGIS status bar. For QGreenland, the current CRS should
be identified as EPSG: 3413, which is the identifier for the NSIDC Sea Ice Polar Stereographic North on a WGS 84
Ellipsoid CRS. Changing the CRS of the Map View will not change the underlying data, though QGIS will do on-
the-fly reprojection of layers not in the selected CRS. It is possible to reproject a layer into a new CRS; however, this
transforms the data and can introduce artifacts. Therefore, it is recommended that to reproject data, the user do so from
the source data and not the data contained in the QGreenland package.

8.3.4 Scale-Dependent Rendering

Scale-dependent rendering refers to the scale at which a particular data layer will be visible in the QGIS map display.
This can make it easier to zoom in and out for certain data layers. The user can turn on scale-dependent rendering for
any layer by going to the layer Properties -> Rendering, checking the box for Scale Dependent Visibility, and then
setting the minimum and maximum scale dependent visibility. For scale reference, refer to the scale indicated at the
bottom of the QGIS interface in the Status Bar.
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Fig. 8.6: The Layer Properties dialog window for the QGreenland ‘Earthquakes’ data layer.

8.3.5 QGreenland Data Layers

A complete list of all QGreenland data layers and their metadata, including information about their original data source,
can be found in the layer_list.csv file included in the QGreenland download package.

8.3.6 Identifying Features in Layers

One of the most basic ways to interact with data in QGIS is to use the Identify Features button in the Attributes
Toolbar to quickly view the attributes of an individual record (i.e., a single point, line, or polygon in a vector layer or
a single cell in a raster layer).

Note: If you do not see the Identify Features button in any of your Toolbars, then you need to toggle on the Attributes
Toolbar. Either right click anywhere in the Toolbar area and check the box next to Attributes Toolbar, or go to View
-> Toolbars in the Menu Bar.

To use the Identify Features button:

1. First, make sure that the layer (not just layer group) that you are interested in is toggled on and selected (click on
it so that the layer is highlighted) in the Layers Panel.

2. Click on the Identify Features button in the Attributes Toolbar.

3. Click on the individual point, line, polygon, or raster cell of interest in the map view. The record for the object
selected will show up in a new Identify Results Panel to the right of the map display (Fig. 8.7).

4. You can choose what information the Identify tool is showing you and how it is displayed by toggling the Mode
and View options at the bottom of the Identify Results Panel.
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Fig. 8.7: The Identify Results Panel that shows results from the Identify Features tool.
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8.3.7 Measuring Distances, Areas, and Angles

Another useful basic tool in the Attributes Toolbar is the Measuring Tool. The Measuring Tool is a quick and easy
way to measure distances between two points or along a line, area of a polygon, or angles between geographic features
or locations.

To use the Measuring Tool:

1. Click on the arrow to the right of the Measuring Tool button and choose if you want to measure a line, area, or
angle. Regardless of which one you choose, a small window will appear.

2. If you are measuring a line distance, first choose your desired units (e.g. kilometers). Ellipsoidal measure-
ments take into account the spherical shape of the earth and the project’s coordinate reference system. Cartesian
measurements assume a flat Earth. For small distances, these numbers will be very similar, but for very large
distances they can be very different.

3. Clicking first on one point on the map and then another will draw a line segment whose length will be indicated
in the Segments box. You can draw and measure multiple line segments.

4. To clear the segments you’ve drawn, click on New.

5. To measure an area instead of a line with the Measuring Tool, you will follow essentially the same steps for
measuring a line distance, except you will click and map out an area on the map instead of drawing line segments.

6. To measure the angle created by three points on the map, click on each of the three points to draw the angle. The
second point you click on will serve as the angle’s vertex.

8.3.8 Adding Text Annotations to the Map View

You can add a text annotation anywhere in the Map View using the text annotation tool in the Attributes Toolbar.

To use the Text Annotation Tool:

1. Click on the text annotation button in the Attributes Toolbar.

2. Click on the place on the map where you want the text annotation to go. A small white box will appear.

3. Double click on the box to open a new window where you can write your annotation and choose the font you
want to use, among other things (e.g., you can link the annotation to a specific layer).

4. When you are done, click Apply and then Ok to close the window.

5. To delete an annotation, double click on it to open the dialog window, then click Delete.

8.3.9 Editing Layer Symbology

Each QGreenland data layer comes with a predefined symbology (how the layer is visualized in the Map View).

To modify a layer’s symbology:

1. Open the Layer Properties dialog window for the layer you want to edit.

2. Go to the Symbology section and modify the layer symbology as desired. a) For a vector layer, you can choose
from a built-in set of QGIS symbols, and/ or can change individual characteristics of the layer’s symbology such
as symbol shape, weight, color, size, opacity, and more. b) For a raster layer, you can change the color properties
of the grid cells, as well as characteristics like brightness and contrast. The opacity/transparency of a raster layer
can be changed in the Transparency tab of the Layer Properties dialog window.
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8.3.10 Processing Toolbox

The Processing Toolbox is what makes the QGIS platform a powerful spatial data analysis tool. The Processing
Toolbox is a collection of tools and prewritten algorithms that allow the user to perform a wide variety of raster and
vector data analyses. For example, the Processing Toolbox contains tools for identifying features in a vector layer that
fulfill certain criteria, extracting selected features from a vector layer and saving them as a new layer, and calculating
vector and raster layer statistics. The Processing Toolbox can be opened in a new panel to the right of the map view
by clicking on the gear icon in the Attributes Toolbar or by going to View -> Panels -> Processing Toolbox Panel
in the Menu Bar.

For more in-depth information about the Processing Toolbox see the QGIS User Manual37

Examples of using the Processing Toolbox with QGreenland data are given below.

Example 1: Selecting from Vector Layers for Specific Features

Which populated regions in Greenland have more than 5000 people?

1. Open the Processing Toolbox and go to Vector selection -> Select by attribute.

2. Fill in the following parameters: -Input layer = Populated places -Selection attribute = Population 2016 -Operator
= ‘>’ -Value = type in ‘5000’ -Modify current selection by = creating new selection These parameters are telling
the program to identify all of the populated places in Greenland that have a population greater than 5000.

3. Click on Run. Close the window when processing is complete.

There are a couple of ways to view the selected data points, populated places in Greenland with more than 5000 people.
First, you should see the places that meet this parameter highlighted in the Map View (make sure the Populated
Places Layer is toggled on). You can also open the Populated places Layer Attribute Table and select Show Selected
Features in the bottom left corner. This will hide all records in the Layer Attribute Table except for the ones you
selected, the locations with populations greater than 5000 people. If you want to create an entirely new layer based
on this feature selection (Population 2016 > 5000), you can do so by either 1) right-clicking on the layer you have just
selected from and choosing Export -> Save selected features as. . . , or by 2) selecting Extract by attribute under
Vector selection in the Processing Toolbox.

Example 2: Vector Layer Statistics

What is the total number of people in Greenland’s populated areas? What is the average size of Greenland’s populated
areas?

1. Open the Processing Toolbox and go to Vector analysis -> Basic statistics for fields.

2. Fill in the following parameters: -Input layer = Populated places -Field to calculate statistics on = Population
2016 -Statistics = Save to temporary file (or whatever your preference is)

3. Click Run.

The Basic statistics for fields window should automatically switch to a view of the Log where you will see the results
for the population basic statistics (Fig. 8.8). The value ‘MEAN’ will tell you the average size of Greenland’s populated
places (702 people). The value ‘SUM’ will tell you the total number of people in Greenland’s metropolitan areas
(55,494 people).

37 https://docs.qgis.org/3.28/en/docs/user_manual/processing/toolbox.html
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Fig. 8.8: Results of Example 2: Vector Layer Statistics
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Example 3: Simple Raster Analysis

What is a good estimate of the Greenland ice sheet’s volume?

See the Calculate the volume of the Greenland ice sheet (page 28) tutorial for an example of how to utilize the Raster
Surface Volume tool.

Example 4: Using the Raster Calculator

How does the maximum sea ice concentration (%) around Greenland and the surrounding land masses in 2021 compare
to the maximum sea ice concentration a decade earlier (2011)?

The Raster Calculator is a tool that allows you to perform calculations on one or more raster layers. For example, if
you wanted to convert a raster layer that is in km2 to mi2, you could use the raster calculator. In this example, we are
going to use the raster calculator to subtract one layer from another.

Note: There is a different Raster Calculator that can be accessed in the Menu Bar by going to Raster -> Raster
Calculator. This calculator is different from the one in the Processing Toolbox used in this example:

1. In the Processing Toolbox, go to Raster analysis -> Raster calculator.

2. In the window that appears, you are going to build a mathematical expression using the layers and operators in
the Expression Box: a) In the Layers box, scroll down and double click on the March2021@1 layer (this is the
layer for the NSIDC’s sea ice concentration data from March 2021). You should see it show up in the Expression
Box in quotations (“ “). b) Either type in the minus (-) symbol or click on it under Operators. It should show
up after the layer you just chose. c) In the Layers box, scroll to and double click on the March2011@1 layer. It
should show up after the minus sign, again in quotations (Fig. 8.10). d) For Reference layer, it’s recommended
you choose either of the two layers used in the expression. Click on the three dots [. . . ] which will open up
another window and allow you to choose the reference layer by checking the box next to the layer name.

3. Click Run and close the window.

The output layer will appear in the Layers Panel (likely named Output). You can right click on it and rename it if
you like. The values next to the colored boxes below the output file (likely black and white boxes) will tell you the
minimum and maximum values of the resulting raster layer. In this case, the numbers will be the difference in the
maximum sea ice concentration (%) between 2011 and 2021, where positive values indicate an increase between 2011
and 2021 (endmember = +80%), and negative values indicate a decrease (endmember = -95%).

8.4 Calculate the volume of the Greenland ice sheet

The Processing Toolbox in QGIS provides a collection of tools and pre-written algorithms that allow the user to
perform a wide variety of raster and vector data analyses. See the QGIS manual38 for complete documentation on the
Processing Toolbox.

In this tutorial, the user will utilize the Processing Toolbox with data in QGreenland to calculate the Greenland ice
sheet’s volume. In doing so, the user will become familiar with the how to use the Processing Toolbox to perform
geospatial analysis.

Warning: This tutorial assumes the user has a basic understanding of GIS and geospatial data models (e.g.,
the difference between raster and vector data). If one if new to GIS, it is reccomended to review QGIS’ Gentle
Introduction to GIS39 first

38 https://docs.qgis.org/3.28/en/docs/user_manual/processing/toolbox.html
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Fig. 8.9: To view the results of the raster surface volume analysis, click on the link next to ‘File path’ in the Results
Viewer Panel below the Processing Toolbox.
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Fig. 8.10: The Raster Calculator expression for Example 4.
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8.4.1 Open the Processing Toolbox

The Processing Toolbox can be opened from the menu bar by selecting View -> Panels -> Processing Toolbox. This
will open a new panel with a variety of processing tools organized into groups.

Note: The Processing Toolbox can also be opened by clicking on the gear icon in the Attributes Toolbar

.

8.4.2 Use the Raster Surface Volume tool

In the Processing Toolbox, go to Raster analysis -> Raster surface volume. This is an algorithm that calculates the
volume under a raster grid’s surface. Double-click Raster surface volume to open the tool’s window, and enter the
following parameters:

• Input layer = Ice thickness (150 m)

• There will only be one option for Band number

• Base level = should already be set to 0. This is the minimum pixel value in the Ice thickness layer.

• Method = Count only above base level (since we are interested in ice thickness values greater than zero)

• Save the Surface volume report, the output for this algorithm, in a temporary file or in a desired location on
one’s computer.

39 https://docs.qgis.org/3.28/en/docs/gentle_gis_introduction/index.html
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Click Run and wait for the analysis to finish. The window will switch to the Log tab, which shows log messages and
results for the run. A Results Viewer panel should open in a panel underneath the Processing Toolbox. Close the
Raster surface volume tool’s window and click on the “Surface volume report” entry in the Results Viewer. This
will show a link to a results HTML page that can be opened in your broswer. Open this file and review the results.
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The results file will contain information from the run, including which file was analyzed, the calculated volume, pixel
count, and total area. If one has succuessfully run the analysis, the results should show that the Greenland ice sheet has
a volume of 2,965,561,810,382,715 m3, or about 3 million km3.

8.4.3 Summary

In completing this tutorial, the user has become familar with the Processing Toolbox and has successfully utilized
the Raster Surface Volume tool with ice sheet thickness data included in the QGreenland core package to calculate
the volume of the Greenland ice sheet. Having accomplished this, the user is now ready to explore other geospatial
processing tools included in the Processing Toolbox to further analyze other QGreenland data.

8.5 Create a layout for print or publication

QGIS is a powerful data viewing and analysis platform, but it is also capable of creating publication-quality maps for
print or publiction. This tutorial covers the basics of creating a new print layout in QGIS, adding a map and map
elements to that layout, and exporting the resulting layout as an image.

See the QGIS manual40 for complete documentation on print layouts in QGIS.
40 https://docs.qgis.org/3.28/en/docs/training_manual/map_composer/map_composer.html
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8.5.1 Creating a new print layout

Once one has created a map in the QGIS Map View that one would like to print or publish, one needs to switch to the
QGIS Print Layout. From the menu bar, select Project -> Print Layout.

Note: The Project Toolbar also contains a button ( )
that creates a new Print Layout.

First, name the new print layout after the figure you plan to create and click OK.

When the print layout window opens, it will be initially blank.
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8.5.2 Changing the print layout’s properties

To change the size and orientation of your print layout, right click in the map area and choose Page Properties. This
will add page size options to the Item Properties panel on the right side of the screen.

8.5.3 Adding a map and other elements

The print layout will allow you to add features to your map such as a title, legend, north arrow, scale bar, pictures, etc
by interacting with the buttons in the Toolbar on the left of the screen.

To add a map to your layout, click on the Add Map button . Click and drag to create a box where the map will
appear on the print layout display.
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To zoom into the region shown in the map or change the extent, click on the Move Item Content button ,
which will make it possible to manipulate the map area within the box.

Now explore some of the other buttons included in the map layout Toolbar. Add a north arrow and scale bar. Finally,
once one is happy with the layout, try exporting the layout as an image by opening the Layout menu and selecting
Export as Image.

8.5.4 Summary

In completing this tutorial, the user has created a new print layout, added a map and other elements to the layout, and
exported the layout as an image. This image can now be utilized in publications or printed to physical media (e.g., a
poster).
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CHAPTER

NINE

HOW-TO GUIDES

9.1 Adding New Datasets to QGreenland

Once the QGreenland Core package is downloaded and extracted onto a user’s computer, it is fully customizable by
the user. One can add new data, delete layers within QGreenland, or make changes. Saving the project will update the
qgreenland.qgz project file. If you do not want to overwrite the original project version, simply save your updated
project using a new filename via Save As. . . You can create as many different projects as you like, adding or removing
data from the downloaded QGreenland package or adding data from elsewhere on your computer.

Note: The QGreenland project uses the EPSG:3413 coordinate reference system (CRS) and all pre-loaded layers are
either GeoTIFF (raster) or GeoPackage (vector) files. Datasets in different CRSs or data formats can still be added to
QGreenland, but may undergo “on the fly reprojection”41.

9.1.1 Adding New Layers in QGIS

To add new data layers to QGreenland in QGIS:

1. In the Menu Bar, go to Layer -> Add Layer, and choose the layer type you want to add. Alternatively, you can
either click on the desired add layer button in the toolbar, or click on the Data Source Manager button in the
Data Source Manager toolbar.

2. Any option you choose will open the same Data Source Manager window. On the right side of the window,
you can double check that the layer type you want to add is highlighted.

3. Navigate to the data file that you want to add as a layer, then click Add.

To learn about adding online-access layers (e.g, WMS, WFS, WCS), see our documentaiton on How to add an online
layer to QGIS (page 44).

41 https://docs.qgis.org/3.28/en/docs/training_manual/vector_analysis/reproject_transform.html#basic-fa-on-the-fly-reprojection
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9.1.2 Selecting for Greenland-Specific Vector Data

Because the geographic extent of some QGreenland data layers extends beyond the geographic and political border of
Greenland to include the surrounding water bodies and land masses, it might sometimes be necessary to filter out certain
data if one is only interested in data within Greenland’s geographic boundary. You can do this using the “Greenland
coastlines 2017” polygon layer.

To filter for data inside of Greenland:

1. Make sure that the group you want the filtered/extracted data to be added to is selected/highlighted in the Layers
Panel.

2. Open the Processing Toolbox and go to Vector selection -> Extract by location.

3. Fill in the following parameters:

• Extract features from = the data layer you want to filter, for example, Ice cores

• Where the features (geometric predicate) = are within (you can also check intersect and others to capture
data that might be located along the Greenland coastline)

• By comparing to the features from = Greenland coastlines 2017

• Extracted (location) = You can either save the file output from this as a temporary layer or as a permanent
layer somewhere on your computer or within your QGreenland data package. Note: If you try to save the
file as a GeoPackage layer (GPKG) and receive an error, try again and save it as a Shapefile (SHP) instead.

4. Click Run and close the window.

The filtered data will show up in the Layers Panel within the group you had selected and likely named Extracted
(location). You can rename the layer by right clicking on it and selecting Rename Layer.

9.1.3 Editing Vector Data Layers

How do you add or delete points, line segments, or polygons to/in an existing vector layer in your QGreenland project?

To edit a vector layer:

1. Select the layer you want to edit in the Layers Panel (click on it so that it is highlighted).

2. Toggle into editing mode by either right clicking on the vector layer you are editing in the Layers Panel and
selecting Toggle Editing or by clicking on the Toggle Editing button in the Digitizing toolbar.

3. With Editing on, you will have access to new editing buttons in the Digitizing toolbar:

• Add new points to a point vector layer

• Add new lines to a line vector layer

• Add new polygons to a polygon vector layer

4. Whenever you create any new vector feature, you will be prompted to enter attribute information for the new
feature for its record in the layer’s Attribute Table.

5. If you just want to edit a record in a vector layer’s Attribute Table, you can open the Attribute Table and click
on the Toggle Editing icon in the table toolbar. Be sure to save the layer edits after you are done making edits.

6. When you’re finished, click on the Toggle Editing button again in the toolbar to disable editing.
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9.1.4 Creating New Vector Layers from Scratch

In your QGreenland project, you may want to create a new vector layer from scratch, such as a point layer of potential
study sites for for your research in Greenland.

To draw a new vector layer from scratch, use the Layer -> Create Layer menu and select one of the following options:

• New GeoPackage Layer (reccomended)

• New Shapefile Layer (not reccomended, see switchfromshapefile.org42).

• New Spatiallite Layer

• New Temporary Scratch Layer (will not persist data to disk!)

In the new window that opens after selecting one of these options, fill out the given options (each will be slightly
different). For detailed instructions on how to add vector layers, see the QGIS documentation43.

Creating a GeoPackage layer

1. In the Menu Bar, go to Layer -> Create Layer -> New GeoPackage Layer or click on the New GeoPackage
Layer button in the Data Source Manager toolbar.

2. A GeoPackage44 is a GIS file format that allows you to save multiple layers in one file; thus, you will actually be
creating a new GeoPackage database that your new GeoPackage layer will live in. In the new window:

• Name your new Database

• Name the new GeoPackage layer you are creating - this is the Table name

• Specify the geometry of the new GeoPackage layer (point, line, etc.)

• Specify the layer coordinate reference system

• Create the fields that will be in the layer’s Attribute Table by giving them a name and indicating their type
(text data, integer, etc.) under New Field. When you click on Add to Fields List, the new field will show
up in the Fields List box.

3. Click Ok. Your new layer will appear in the Layers panel. If it is within another Group you do not want it in,
right click on it and select Move Out of Group. You can also drag and drop your layer into the location you
want it.

9.1.5 Creating a Custom Clipping Boundary Polygon

You can create your own custom boundary polygon layer to extract features from. Follow the instructions above on
Creating New Vector Layers from Scratch (page 40) to draw a polygon layer from scratch. Then, follow the instructions
on Selecting for Greenland-Specific Vector Data (page 39) to extract features from vector layers using the custom
polygon boundary layer instead of the “Greenland coastlines 2017” layer.

42 http://switchfromshapefile.org/
43 https://docs.qgis.org/3.28/en/docs/user_manual/managing_data_source/create_layers.html#creating-new-vector-layers
44 http://www.geopackage.org/
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9.1.6 Importing GPS and other GNSS Data

QGIS supports importing Global Positioning System (GPS) and other Global Navigation Satellite System (GNSS) data
from GPS Exchange Format (GPX) datasets. In the Menu Bar, go to Layer -> Add Layer -> Add GPX Layer.

QGIS can also interface with a GPS device to download data directly and provide live tracking.

Please see the QGIS documentation on Working with GPS Data45 for more information.

9.2 How to Locate Layer Metadata

Metadata refers to the general information about a data file, and the metadata for QGreenland layers can be accessed in
two ways.

Note: For more information on layer properties and metadata, see our Tutorial on Interacting with Geospatial Data
in QGreenland Core (page 20).

9.2.1 Via QGIS Layer Properties

If you have the QGreenland Core base package downloaded, you can easily locate and view layer metadata within QGIS.
First, open the qgreenland.qgzQGIS project file that was included in the QGreenland Core download package. Next,
locate your layer of interest in the Layer Panel. The Layer Panel is a panel on the left side of the Map View containing
a list of layers that are in your QGIS project.

45 https://docs.qgis.org/3.28/en/docs/user_manual/working_with_gps/index.html
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Right click on the layer and select the Properties option. This will open the Layer Properties window. Next, find the
metadata tab on the left side window panel. This will show any available information that is associated with the data
layer, including the title and abstract.
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Information about the layer’s coordinate reference system and spatial extent can be found in the Information tab.

9.2.2 Via Text Files in Layer Directories

In each layer directory inside the QGreenland package, you should see 2 text files, one provenance.txt, which
includes information on how the data is processed, and one metadata.txt.

Open up metadata.txt to read through the layer metadata including layer description, dataset abstract, and citation
information.

Open the provenance.txt file to see all of the processing steps applied to the data for QGreenland.

Note: To see the layer’s geospatial metadata (e.g., the coordinate reference system and spatial extent), we recommend
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using QGIS (page 41).

9.3 How to add an online layer to QGIS

When access to the internet is available, QGIS is capable of connecting to various online map services that can provide
access to additional geospatial data that compliments QGreenland. Common map services include:

• Web Map Service (WMS)46: Provides image representations of geospatial data.

• Web Coverage Service (WCS)47: Provides access to raster data

• Web Feature Service (WFS)48: Provides access to vector data

This how-to guide covers creating a new connection to a WMS and adding a layer from that service. WCS, WFS, and
other online services can be interacted with in a similar way.

For more information about adding online layers, see the following resources from QGIS:

• Online resources tutorial49

• OGC web services user manual50

9.3.1 Add a WMS Layer

First, open the “Data Source Manager” from the top Menu Bar (Layer -> Data Source Manager) and select the
“WMS/WMTS” option.

Click “New” to add a new connection to a WMS server. In this example, we will be using the National Snow and
Ice Data Center’s (NSIDC). Add a descriptive name (e.g., ‘NSIDC’) and add the following URL to the “URL” field:
https://nsidc.org/api/mapservices/NSIDC/wms?version=1.1.0.

46 https://www.ogc.org/standards/wms
47 https://www.ogc.org/standards/wcs
48 https://www.ogc.org/standards/wfs
49 https://docs.qgis.org/3.28/en/docs/training_manual/online_resources/index.html
50 https://docs.qgis.org/3.28/en/docs/user_manual/working_with_ogc/ogc_client_support.html
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Note: Additional information about NSIDC’s web map services is available here: https://nsidc.org/map-services/
geospatial-map-services.

For additional online resources, see the Online layers reference (page 53) page.

Click “OK”. This will create and select a new server connection to NSIDC’s WMS that can be re-used between sessions
of QGIS.

Click “Connect”. This will populate a list of available layers for the currently selected server.
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Use the search bar or scroll to the nsidc_0478_v2_measures_greenland_ice_sheet_vel layer and select it. This
layer provides a visualization of Greenland ice sheet velocity. See NSIDC’s documentation for this dataset for more
information: https://nsidc.org/data/nsidc-0478.

Finally, click “Add”. The layer will be added to the Layers Panel in QGIS.

Warning: The added layer will be inserted below whatever layer was previously selected in the Layers Panel.
This may mean that the layer is covered by other layers above it. If the layer does not show up within a few seconds,
check which layers are above the inserted layer and reorder as needed.
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Note: Some online layers are a timeseries. QGIS will automatically detect layers with a time component and identify
them as such with a clock icon next to the layer name in the Layers Panel.

Temporal Layers can be interacted with using the Temporal Controller panel. See the QGIS documentation51 for
more information about time-based control of the map canvas.

9.4 Troubleshooting

Contents

• Difficulty opening the project (page 47)

– QGIS will not start on OSX Catalina (page 48)

– ‘Unable to open’ from QGIS when opening project (page 48)

– No layers are present in the Layers Panel (page 48)

• Difficulty using the project (page 48)

– After opening QGreenland, I only see blue ocean (page 48)

– Too many open files on Linux (page 48)

– I see ERROR: Too many connections: max 64 in my terminal (page 49)

– The QGIS interface has no buttons or toolbars (page 49)

– I cannot see a layer in the Map View even though it is turned on and I have zoomed to it (page 49)

– When I open QGreenland, I get the warning Font "Helvetica" not available on system
(page 49)

– When I open QGreenland, I get the warning This project file was created by a newer
version of QGIS (page 49)

– Navigating QGIS errors (page 50)

• I am having other problems. How do I contact the QGreenland team? (page 50)

9.4.1 Difficulty opening the project

If you are having trouble opening the project, first ensure you are using QGIS 3.16 LTR or greater. If you want to
move QGreenland to a different location on your filesystem, move the entire directory; do not attempt to move only the
.qgs/.qgz project file.

51 https://docs.qgis.org/3.28/en/docs/user_manual/map_views/map_view.html#maptimecontrol
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QGIS will not start on OSX Catalina

QGIS is currently not ‘notarized’ for Mac OSX. If you receive The developer of this app needs to update
it to work with this version of macOS. Contact the developer for more information., then, in
your OSX menus, try:

• ‘Security and Privacy’

• ‘Allow apps downloaded from. . . ’

• ‘App Store and identified developers’

• Locate QGIS here and select ‘Open anyway’

‘Unable to open’ from QGIS when opening project

If you opened QGreenland from the command line, ensure you got the project name correct. E.g., from inside the
unzipped QGreenland directory:

qgis qgreenland.qgz

No layers are present in the Layers Panel

If you do not see layers in the Layers Panel, you have not correctly opened a project. Click Project in the Menu Bar,
then select Add Project, then navigate to your QGreenland directory, wherever you saved it, and open the .qgs/.qgz
file inside.

9.4.2 Difficulty using the project

After opening QGreenland, I only see blue ocean

Right click on a layer in the Layers Panel that you would like to view, and select Zoom to Layer.

If you experience this issue, please contact us52 with information about your Operating System and QGIS version. A
small number of users have reported this issue, but we haven’t been able to identify the cause thus far.

Too many open files on Linux

Your system may have multiple ways of limiting open files in different contexts. To check your limits:

ulimit -Sn # soft limit
ulimit -Hn # hard limit

Edit the /etc/security/limits.conf to add or update rules that apply to your user. If there are no rules, you can
try adding:

* soft nofile 20480
* hard nofile 1048576

If your system uses systemd, also edit the /etc/systemd/system.conf and /etc/systemd/user.conf files to
ensure the following variable is set to a large value in both files:

52 qgreenland.info@gmail.com
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DefaultLimitNOFILE=20480

After applying these changes, you may find that new terminal windows are not affected. Reboot your computer to make
the changes permanent.

I see ERROR: Too many connections: max 64 in my terminal

We do not think this is an issue. This started happening when we switched to GeoPackages for vector data, but we have
observed no negative impact of this error message.

The QGIS interface has no buttons or toolbars

Right-click the toolbar area in the QGIS interface and check the toolbars you wish to turn on so that they are displayed.
You can also go to View -> Toolbars in the Menu Bar.

I cannot see a layer in the Map View even though it is turned on and I have zoomed to it

Double-check that there is not another layer overlaying and thus obscuring the layer you want to see in the Map View.
Remember that layer are displayed in the Map View in the same order that they are listed in the Layers Panel - layers
listed at the top of the Layers Panel show up on top on the Map View. You can either turn off any layer that might be
obscuring the layer you wish to see by unchecking it in the Layers Panel, or re-arrange the order of layers by clicking
and dragging them up or down in the Layers Panel.

Some QGreenland data layers are only visible at a specific map scale (see QGreenland User Guide section 4.3.1:
Scale-dependent rendering (page 22) for more information). Try zooming in.

When I open QGreenland, I get the warning Font "Helvetica" not available on system

Please upgrade to QGreenland v3 and a supported version of QGIS (>=3.28).

For more context, see the GitHub issue53.

When I open QGreenland, I get the warning This project file was created by a newer version of
QGIS

For example:

This project file was created by a newer version of QGIS (3.28.8-Firenze) and could not
be completely loaded.

We have not observed any adverse effects from this warning. If you want to get rid of the message permanently, update
to the latest release of a supported QGIS version.

53 https://github.com/nsidc/qgreenland/issues/515
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Navigating QGIS errors

If you are opening QGIS using a terminal or using the QGIS Python console, it is possible you might see one of a few
different error messages while using QGIS that the QGreenland team has determined can be ignored:

-Warning: Logged warning: Creating Warped VRT This error message is likely triggered by a raster layer in the
QGreenland project but should not have any impact on the data layers or project usability.

-ERROR: Too many connections: max 64 This error is thought to be related to the GeoPackage file format but should
not have any impact on the layers themselves or the project usability.

9.4.3 I am having other problems. How do I contact the QGreenland team?

If you have feedback or questions about the QGreenland data package, or want to contribute datasets to future QGreen-
land releases, please participate in our GitHub Discussions54 space. If you’re uncomfortable with or otherwise can not
participate there, please contact us directly at qgreenland.info@gmail.com.

54 https://github.com/nsidc/qgreenland/discussions/
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CHAPTER

TEN

REFERENCE

10.1 Glossary

A “user” is someone who uses QGreenland in QGIS.

10.1.1 QGreenland Core

QGreenland Core is a large zip package curated to cover a broad variety of disciplines within a reasonable file size.

10.1.2 QGreenland Custom

Attention: QGreenland Custom is no longer supported.

QGreenland Custom is a QGIS plugin that enables users to download and use only the QGreenland layers they are
interested in.

10.1.3 QGreenland Modules

QGreenland modules are subsets of the QGreenland layers intended for more targeted use. Modules include:

• QGreenland Core: Covers a wide variety of disciplines and scientific needs. Curated to be useful for the largest
number of users.

10.1.4 Defined Terms

• Attribute: Information about the components of a vector layer listed in tabular form. For example, a possible
attribute of a point vector layer of cities is city name or population.

• Coordinate Reference System (CRS): The system used to reference the x and y coordinates of a dataset.

• Layer: A set of data and its symbology.

• GeoPackage Layer: A collection of one or more data layers, including points, lines, and polygons, that are saved
as a single file. A GeoPackage layer is an open format and platform-independent using SQLite.

• Shapefile Layer: A proprietary vector layer format (points, lines, polygons) developed and regulated by Esri,
but usable in QGIS.
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• SpatialLite Layer: A way to store an entire spatial database in one file; a spatial extension to SQLite, a relational
database management system.

• Temporary Scratch Layer: A temporary layer formed as a result of a spatial query of analysis that is discarded
when QGIS is closed.

• Virtual Layer: A specific kind of vector layer that results from an SQL query.

• Layer Group: A collection of multiple layers that are related to one another.

• Raster: A layer type consisting of grid cells or pixels, where each cell has a specified value.

• Vector: A layer type consisting of either points, lines, or polygons, where each point, line, or polygon has a
unique set of attribute values.

10.2 Online layers reference

QGreenland can be enriched with layers provided by online services such as Web Map Service (WMS)55, Web Feature
Service (WFS)56, and Web Coverage Service (WCS)57. This document provides a list of potentially useful resources
that QGIS can connect to to provide layers via the internet.

See the How to add an online layer to QGIS (page 44) page for information on how to utilize these resources.

• The National Snow and Ice Data Center (NSIDC)58 [WMS, WFS, WCS] provides access to a wide variety of
datasets.

• The Arctic Observing Viewer59 [WMS, WFS] provides observing sites associated with long-term monitoring
activities in the circumarctic.

• The Arctic Research Mapping Application60 [WMS, WFS] provides a variety of reference layers such as Arctic
cities and an Arctic base map.

• The Geological Survey of Denmark and Greenland (GEUS)61 [WMS, WFS] provides various layers including a
geological occurrence map. Note that GEUS requests that users of its services provide an email address as part
of each request. Results may be limited during peak service hours.

• The National Aeronautics and Space Administration (NASA)’s Global Imagery Browse Service (GIBS)62

[WMS/WMTS] provides quick access to over 1000 satellite imagery products. For instructions on how to utilize
GIBS with QGIS, see the Earthdata Wiki on GIBS63

• The https://dataforsyningen.dk/data[WMS, WMTS, WFS, WCS] provides reference data from the Danish
Agency for Data Supply and Infrastructure Data Portal (SDFI) and other partner insutitions. Users must reg-
ister an account before accessing data. Note that the website is in Danish and can be translated to English via
Google Translate64.

55 https://www.ogc.org/standards/wms
56 https://www.ogc.org/standards/wfs
57 https://www.ogc.org/standards/wcs
58 https://nsidc.org/map-services/geospatial-map-services
59 https://arcticobservingviewer.org/web-services/
60 https://armap.org/web-services/
61 http://maps.greenmin.gl/geusmap/ows/help/?mapname=greenland_portal
62 https://earthdata.nasa.gov/eosdis/science-system-description/eosdis-components/gibs
63 https://wiki.earthdata.nasa.gov/display/GIBS/Geographic+Information+System+%28GIS%29+Usage#expand-QGIS
64 https://translate.google.com/

10.2. Online layers reference 53

https://www.ogc.org/standards/wms
https://www.ogc.org/standards/wfs
https://www.ogc.org/standards/wfs
https://www.ogc.org/standards/wcs
https://nsidc.org/map-services/geospatial-map-services
https://arcticobservingviewer.org/web-services/
https://armap.org/web-services/
http://maps.greenmin.gl/geusmap/ows/help/?mapname=greenland_portal
https://earthdata.nasa.gov/eosdis/science-system-description/eosdis-components/gibs
https://wiki.earthdata.nasa.gov/display/GIBS/Geographic+Information+System+%28GIS%29+Usage#expand-QGIS
https://dataforsyningen.dk/data
https://translate.google.com/


Part V

Discussion topics

54



CHAPTER

ELEVEN

DISCUSSION

11.1 About the QGreenland project

Greenland-focused research, planning, and education crosses disciplinary boundaries. With QGreenland, a free and
open data platform, anyone can explore a wide variety of Greenland-focused data identified by an expert team and
Editorial Board65.

QGreenland is a United States National Science Foundation EarthCube-funded effort (award #192839366). Project de-
velopment began in 2019, led by the National Snow and Ice Data Center67, which is a part of the University of Colorado
Boulder Cooperative Institute for Research in Environmental Sciences68. In 2023, a second award (#232476569) was
granted, enabling continued work on QGreenland. The project is made possible through the generous efforts of a wide
range of collaborators.

The QGreenland Team believes in open and accessible resources. QGreenland is built using free and open software,
with development tools and workflows fully documented on our Github page70. We also believe in FAIR (findable,
accessible, interoperable, reproducible) data and strive to include clear information about original data sources and
complete metadata. To the best of our ability, we aim to include data that are already free and publicly archived.

As QGreenland development continues, we will be expanding our educational resources, increasing optional data down-
load options, and working to be as responsive as possible to user feedback. We look forward to hearing from you on
GitHub Discussions71 or by email72.

11.2 QGreenland Custom QGIS Plugin

Attention: QGreenland Custom is no longer supported.

QGreenland Custom was an experimental QGIS Plugin for downloading a custom set of data, including data which
is not part of the QGreenland Core zip package (for example, due to filesize constraints).

The plugin is no longer under active development and should not be expected to work.

See the QGreenland Custom Documentation73 for more information.
65 https://qgreenland.org/our-team
66 https://nsf.gov/awardsearch/showAward?AWD_ID=1928393&amp;HistoricalAwards=false
67 https://nsidc.org/
68 https://cires.colorado.edu/
69 https://www.nsf.gov/awardsearch/showAward?AWD_ID=2324765
70 https://github.com/nsidc/qgreenland
71 https://github.com/nsidc/qgreenland/discussions
72 qgreenland.info@gmail.com
73 https://qgreenland-plugin.readthedocs.io/en/latest/
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11.3 What is next for QGreenland?

The release of v3 completes QGreenland’s original grant funding provided by the NSF’s EarthCube program and marks
the start of planning for our next award.

11.3.1 QGreenland: Enabling Science through GISPage 56, 74

Under this grant, we released QGreenland v1, v2, and v3. The QGreenland team also hosted virtual (e.g., 175, 276)
and in-person workshops, developed educational materials, and participated in conferences and travel to Denmark and
Greenland.

11.3.2 QGreenland-Net: Open, connected data infrastructure for Greenland-
focused geoscience, and beyond77

Under QGreenland’s next award, we will focus on developing community practices for data customization that QGreen-
land and other communities can leverage to create consistent geospatial data packages. Learn more here78.

You can keep up-to-date by:

• Subscribing to the QGreenland newsletter79

• Following our activity in GitHub80, where we do our work in the open. Our GitHub Discussions81 space may be
of particular interest to follow or participate in discussions about our future direction.

74 https://www.nsf.gov/awardsearch/showAward?AWD_ID=1928393
75 https://qgreenland-workshop-2023-researcher.github.io/
76 https://qgreenland-workshop-2023-educator.github.io/
77 https://www.nsf.gov/awardsearch/showAward?AWD_ID=2324765
78 https://www.nsf.gov/awardsearch/showAward?AWD_ID=2324765
79 http://eepurl.com/gQ7VCr
80 https://github.com/nsidc/qgreenland
81 https://github.com/nsidc/qgreenland/discussions
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